Main Menu

Data Menu

All data management commands explained below applies to the main window and record listing tabs. They do not apply to an open record details window. Remember to use the toolbar of the record window if you want to execute tasks for an open record window.

New: Opens a new blank record window to create a new record in the current catalog.

Reload: Refreshes most of the data objects like currently shown record listing and catalog tree.

Copy: Copies data from the currently selected record(s) to clipboard which you may paste to any 3rd party application. You may configure the formatting used for copied data from Preferences window.

Print: Opens print dialog to print currently selected record(s) from record list.

Remove Protection: Removes the protected/locked status of the currently selected record on record list window.

Import: Imports records from a file into the current catalog.

Export: Exports selected records to a file from the current catalog.

Logout: Restarts SpeedBase and displays login window. If you had configured SpeedBase to remember your password before, this command wipes out the password from memory and you (or the next user for multiuser licenses) have to login with your username and password.

Restart: Restarts the application.

Exit: Closes all open windows and terminates SpeedBase application. When you use "Exit" command, no process related to SpeedBase remains running in memory. Reminders will not be displayed untill the application is started again.

Caution! When you simply close the main window from [X] button, SpeedBase will stay running in the memory and continue processing reminder/instant messages if any. You must use "Exit" command if you want to terminate the application completely.


Recent Menu

Displays an automatically updated shortcut list of most recently opened records. Clicking any of those shortcuts will instantly reopen that record.
The recent menu can be turned off from preferences window.

Clear History: Deletes all shortcuts from the recent menu. This will not affect any data in your database.


Users Menu

Most of the features available under this menu are available on multiuser licenses only.

Users: Opens the users window which allows you to manage SpeedBase users and their access rights.

User Groups: Opens the user groups window which allows you to manage multiple user groups for easier management of access rights.

Access Rights: Opens "Advanced Access Rights" window which is used to apply security exceptions to have extended control above access control.

Change Login Password: Allows the current user to change his/her own password used to login to SpeedBase.


Tools Menu

Global Search: Opens global search window to do a search across all data in your database.

Mass Replace: Opens "Mass Replace" window to replace data on a certain field for all selected records.

Duplicate Finder: Opens "Duplicate Finder" window to search for duplicate records based on a set of matched fields.

File & Image Gallery: Opens "File Gallery" window which allows you to browse and search thru all file and image attachments that are attached to records.


Design Menu

Catalogs: Opens catalog management window which is the starting point to build the database structure (catalogs, information fields, data input forms, relationships etc.)

Fields: Opens "Field List" window to create/modify/delete data fields of the selected catalog. Identical to the popup menu command displayed when you right click a catalog from catalog tree.

Form Designer: Opens "Form Designer" window to design the record input/display form of the selected catalog. Identical to the popup menu command displayed when you right click a catalog from catalog tree.

Relationships: Opens relationship management window to create, modify or delete relationships between catalogs. Identical to the popup menu command displayed when you right click a catalog from catalog tree.

Views: Opens view management window to create, modify or delete views of the selected catalog. Identical to the popup menu command displayed when you right click a catalog from catalog tree.

Report Manager: Opens "Report Manager" window to create and edit custom report templates.

Import Application Template: Imports a database design template from file.

Export Application Template: Exports current database design template to file.

Database Menu

Connection: Opens "Connection Settings" window to setup database connection parameters and data folder location.

SQL Query: Opens "SQL Query" window.

Scheduled Tasks: Opens "Scheduled Task" window where you may create scheduled tasks to run scripts.

Preferences: Opens "Preferences" window to modify system settings as well as user level preferences. See System Preferences and User Preferences: for details.

Information: Opens a window which displays informative data about your database, connections and license status.

Backup & Restore: Allows you to configure backup settings, create or restore backups.

Import Database: Imports selected database file and then connects to it.

Clone Database: Creates and exports an identical file copy of your current database with all records wiped out.

Create New Database: Opens the "create database" window where you can drop current database connection and create a new, empty database.



Help Menu

Help & Support Center: Opens online help & support center page in your web browser.

Documentation: Opens online help documentation in your web browser.

Upgrade: Opens version upgrade page in your web browser which will guide you to get the most recent version of SpeedBase.

Send Feedback: Allows you to send your opinions and suggestions to the developers.

Register SpeedBase: Displays registration window to convert your trial version to registered full version or update your license key to enable a feature upgrade.

Buy Now: Opens order page in your web browser to purchase SpeedBase products and services.

About SpeedBase: Displays about window with version and registrant information.






Online Help Home Page   ::   SpeedBase Software Home Page